Elium is supported on:

  • CHROME: Two latest versions

  • FIREFOX: Two latest versions

  • FIREFOX ESR: Latest ESR

  • SAFARI: Two latest versions

  • EDGE CHROMIUM: Two latest versions

Did this answer your question?